2.7' e-Paper Hat

Hello all! I have been looking though the forums and slack and to no avail I have not been able to solve my problem. My e-Paper Hat is not displaying anything
I have flashed my SD card and setup a config file and I followed the steps on the waveshare website to configure a e-Paper Hat display with the pi
I have a 2.7 inch e-Paper HAT and within the config file I changed the type to ‘waveshare27inch’ but still nothing has worked for me. Is there anyone that can point me in the right direction of what I can do next to go forward?

Hi have you got the config.yml file displaying:

enabled: true

that might be the issue.

Hey Daemonllama,

Thank you for the response! This is what my config looks like currently


I thought maybe I had shorted out the screen by attaching it backwards, but I got a new one in today and the same problem is persisting. When capturing the logs the pwnagotchi seems to hang up at starting the display

There might be a problem with the yml file. Have you tested it with an online yml checker? yml is very fussy about format. I’m still quite a noob to linux, but I’m suggesting trying things that I was able to use to get problems sorted. I was able to get my waveshare27 to work, but every time the screen refreshed, it would go completely white, then completely black, and then refresh, and it was cycling every 15 or so seconds.

I thought I replied to this earlier!

In case anyone else has this issue or is looking to attach a display to their PI, you need to solder the header on. I though that the copper pads against the pins would be enough to get it working with no issue, boy was I wrong.

If you don’t want to solder, you might buy a Pi zero with the headers already soldered on.

So, I had the same issue and documented it over on Reddit. Reddit Post
For me it was a defect RP0W. I ordered a new one and everything worked. You can have a look at the steps I took to figure this out, but be prepared to order a new one if the problem isn’t solved.

Oh, nvm. You already solved it. I guess I didn’t quite read everything here. Just saw the title… Glad that you were able to figure this out.