Bluetooth connection with Macbook

Hi - I was wondering if anyone had any luck connecting pwnagotchis to a macbook via bluetooth? I can get mine to “connect” but I dont think that it is actually connecting to the internet (no handshake uploads) and cant load the web UI page. Ive tried turning ON "internet sharing) in system preferences/sharing… even bluetooth file sharing - no luck.
Do i need to manually configure the Bluetooth PAN? By default, Network Connections has it configured automatically and shows that it is “Yellow” and not connected. Ive tried configuring it manually as described here and the PAN then shows as “connected” but no devices listed nor signs on connectivity from the pwnagotchi. (would be nice if there was a little bitmap internet connection icon for debugging…)
Running Sierra. Any suggestions are greatly appreciated

Still working on this.
What I’ve found works so far is to check (on your pwnagotchi) - whether your Mac has been seen by pwnagotchi, has paired with it, and has trusted it.

You want also want to verify that your BT-TETHER settings in /etc/pwnagotchi/config.yml are correct.

  • meaning you’ve enabled the plugin
  • you have the correct bdaddress/ bluetooth device address for your Mac
    ** I’ve set my Mac as an ios-phone entry
  • you’ve set the priority

  • execute on your pwnagotchi: sudo bluetoothctl
  • ensure that you replace FF:FF:FF:FF:FF:FF w/ the BTAddress of your Mac
 [bluetooth]# devices
 [bluetooth]# scan on
 [bluetooth]# pair FF:FF:FF:FF:FF:FF
 [bluetooth]# trust FF:FF:FF:FF:FF:FF
 [bluetooth]# scan off
  • you want to get success on pair and trust

You should then be able to see: bnep0, so exec:
ip addr show bnep0 | awk '/inet / {FS = "/"; $0 = $2; print $1}', to confirm that it is receiving an ip.

You can also tail the logs to check for BT info

  • dmesg -T | grep Bluetooth
  • sudo tail -F /var/log/syslog | grep Bluetooth
  • sudo tail -F /var/log/pwnagotchi.log | grep Bluetooth

Where I’m at:

  • I think for macOS we need to ensure that both it and the RPi0W can participate in the BT-PAN profile.
  • I’m still debugging, but need some time to dive deeper in.

thanks for the reply. I am paired ( done manually, pair and trust too) and have no issues actually connecting. It does it automatically is the macbook’s BT is on. bnep0 is receiving the IP - the config settings for the mac are pretty much the same as with my iphone,-which works well. (priority and search order are changed) It seems to me that the issue is one the macbook side, but you might be right in that the pwnagotchi isnt “participating” properly

Hey guys,

Any luck, anybody?

So far I have following configuration

      enabled: true
          enabled: true
          search_order: 1
          priority: 1
          mac: '8C:85:90:DD:55:44'
          ip: ''
          netmask: 24
          interval: 1
          scantime: 5
          share_internet: true
          max_tries: 0
          enabled: true
          search_order: 2
          priority: 2
          mac: '3C:28:6D:55:99:66'
          ip: ''
          netmask: 24
          interval: 1
          scantime: 5
          share_internet: true
          max_tries: 0

pwnagotchi has no issues to connect to my phone
As for macbook, pwnagotchi connects to it and disconnects after like 3 seconds