Bluetooth tethering working but no internet connection

So my Pwnagotchi is tethered to my phone via bluetooth, I can connect to it via SSH and WebUI, but I can’t ping hostnames or IP addresses unless I run sudo route add default gw 192.168.44.1 bnep0. Which I have to run that every time I boot the Pwnagotchi. After that I can only ping IP addresses, but not hostnames. Can anyone help with this?

CrashOverride:~ $ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 10.0.0.1 0.0.0.0 UG 0 0 0 usb0
10.0.0.0 0.0.0.0 255.255.255.0 U 0 0 0 usb0
192.168.44.0 0.0.0.0 255.255.255.0 U 0 0 0 bnep0
CrashOverride:~ $ ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.

— 1.1.1.1 ping statistics —
9 packets transmitted, 0 received, 100% packet loss, time 300ms

CrashOverride:~ $ ping google.com
ping: google.com: Temporary failure in name resolution
CrashOverride:~ $ sudo route add default gw 192.168.44.1 bnep0
CrashOverride:~ $ ping google.com
ping: google.com: Temporary failure in name resolution
CrashOverride:~ $ ping 1.1.1.1
PING 1.1.1.1 (1.1.1.1) 56(84) bytes of data.
64 bytes from 1.1.1.1: icmp_seq=1 ttl=53 time=181 ms
64 bytes from 1.1.1.1: icmp_seq=2 ttl=53 time=79.7 ms
^C
— 1.1.1.1 ping statistics —
2 packets transmitted, 2 received, 0% packet loss, time 2ms
rtt min/avg/max/mdev = 79.715/130.543/181.371/50.828 ms
CrashOverride:~ $ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.44.1 0.0.0.0 UG 0 0 0 bnep0
default 10.0.0.1 0.0.0.0 UG 0 0 0 usb0
10.0.0.0 0.0.0.0 255.255.255.0 U 0 0 0 usb0
192.168.44.0 0.0.0.0 255.255.255.0 U 0 0 0 bnep0

I found the issue… at least for me it was. and I feel insanely stupid for missing this…In the config.toml under the bluetooth section. There is a spot that says main.plugins.bt-tether.devices.android-phone.share_internet = false All I did was change it to true, did a reboot and everything worked fine.