Enable an External Wifi card

what hardware are you using

Alfa or tplink , want increased range

I’m running pwngotchi on a rpi3 and the USB settings are unnecessary for me. I got it connecting to my network And scping the hs’s to my desktop.

So to get the alfa working, havent had luck with the tplink yet needs drivers or something, you need to disable onboard wifi with the following commands as root

$ echo “dtoverlay=pi3-disable-wifi” | sudo tee -a /boot/config.txt
$ sudo reboot now

this will disable onboard wifi and allow your alfa card to be wlan1 which on startup turns into mon0. I am messing around with the TP-link dongle still and checking for drivers after i get some other stuff setup.

1 Like

it is described in https://pwnagotchi.ai/installation/#installing-on-any-gnu-linux

1 Like

This could be interesting. I think it would be great to switch between internal nic to external one (e.g. Alfa) once it is usb-connected, in an automated/faster way.

I really don’t know if it is possible or not, but I could be discouraged to use external nics if I have to manual modify the configuration via ssh every time.

Maybe it can be possible to make Pwnagotchi check for usb nics at boot, and use it instead of internal one? So it could be possible to just reboot it to make it work?

and what if there’re 2 wifis, or 3? the user would need to select it anyway … nope, i’d say the way it is right now is good enough :+1:

1 Like

You mean running pwnagotchi on the pineapple wifi module? Haven’t tried that one yet…

I have tried using both a AWUS036NHA and a TL-WN722N, with a Pi3. I have added “pi3-disable-wifi” to the /boot/config.txt but whenever the pi powers on with either wifi adapter plugged in I ssh into the pi using lan then I can see the wifi adapter light up, it blinks a little and then it freezes, and won’t let me type anything into terminal. Any ideas?

1 Like

just to follow, insterested too

1 Like

Isnt this idea is great? I got a TP-Link TL-WN725N (nano) and a TL-WN722N (high gain). Wouldt this be awsome in aspect to the range? As far as I know the raspberry pi zero does only support 2.4GHz WLAN networks. But 5GHz is interesting too I guess. Anybody want to look into it with me?

Sure, if there is an easy way to attach an wifi adapter to the pi zero… :slight_smile: Simply didnt had the time yet to look into this…
It would also free up the internal WiFi that could be used to connect to the home WiFi and simplify the connection to the internet…?

I think the easiest thing to do is buy a network adapter that is already compatible with pi zero.

I use these:

Then run these commands:

sudo su
echo 'auto mon1' >> /etc/network/interfaces.d/wlan1-cfg
echo 'iface mon1 inet manual' >> /etc/network/interfaces.d/wlan1-cfg
echo   'pre-up iw wlan1 interface add mon1 type monitor' >> /etc/network/interfaces.d/wlan1-cfg
echo   'wireless-mode monitor' >> /etc/network/interfaces.d/wlan1-cfg
sed -i 's/mon0/mon1/g' /usr/bin/bettercap-launcher

If you want to revert to the onboard wireless run this command:

sed -i ‘s/mon1/mon0/g’ /usr/bin/bettercap-launcher

1 Like

FYI if you use an external adapter the pi zero is probably not going to be able to provide it enough power. You might find that this makes your pi unstable. If that is the case you may need to buy an external battery pack that has multiple ports. Then use one of these cables to inject power into the wifi adapter. https://www.amazon.com/Onvian-Splitter-Adapter-Charging-Syncing/dp/B01KX4TKH6/ref=sr_1_3?keywords=usb+power+splitter+cable&qid=1576174125&sr=8-3

1 Like

tried this script, didn’t work for me with an alfa 036NHA

I might have made a mistake thought… that said, It did disable the internal card, but when booting with the alfa card plugged in, it couldn’t scan for anything and the alfa blue activity light didn’t go on at all. Maybe it needed more power, I just plugged it in directly to the data port. Also, on the wavesharev2 screen it showed it wasn’t picking up any APs, could also be a driver issue.

Ifconfig and return output here.

here’s where i’m at.

punched in the script, booted up, took a longer than usual time to boot, eventually got it paired over bluetooth to ssh in, the face showed up as having no networks and didn’t scan at all

here’s the ifconfig

i had a look at the file that the script seemed to be editing, here’s what was inside

I also tried a lower power usb netgear WG111v2, but didn’t fare much better than the alfa card

The only thing my script does is tell it to use mon1. Since I don’t see mon1 interface it will never work. Try to use the hardware I’ve outlined here - Pwnagotchi 5GHz with case Otherwise troubleshoot the wireless adapter until you can get it to show up as well as mon1.

1 Like

I wish he would also explain exactly what the linked code does.

The way he writes it with >> and such I have never seen before as an example.

I assume >> means you then sudo nano into that wlan1-cfg file and dunno what then lol.

Total confusion in the head of someone trying to learn.

if your script is just saying to use mon1, how do you go about creating mon1?