Mini guide debugging GPS

mini guide debugging GPS

identify the serial port for your usb gps module

$ dmesg | grep tty | grep -i usb
[  197.458376] cdc_acm 1-1:1.0: ttyACM0: USB ACM device

#identify the baudrate
odds are your baudrate will be 9600

check for gps lock

where your device is “ttyACM0”

$ grep "GPGSA" --line-buffered < /dev/ttyACM0

– this is bad


– this is good


great now you have a gps lock.

update your config.yml

          enabled: true
          speed: 9600
          device: /dev/ttyACM0

restart pwnagotchi service

touch /root/.pwnagotchi-auto && systemctl restart pwnagotchi



So it looks like the 1.3.0 release contained some gps plugin fixes, 'cause the pwnagotchi is now seeing my gps. Whereas before I had a fix and could see data on the cli, but the pwnagotchi plugin wouldn’t load, the problem now is I get no fix from the gps. Went through these steps, as well as plugging the module into my laptop and looking at the streaming data via screen. Screenfuls of $GPGSV data indicating it’s picking up satellites, but still nothing in the $GPGSA line that would indicate it’s getting a fix. Did I somehow brick my gps device, or is it just really shitty at getting a fix indoors (Had no problem indoors at home. This is at work though, 2nd floor of a 3-story building.)? I went outside and let it run for a couple minutes on the pi, after rebooting, but still no fix there either.

Hello guys I have a U-blox 7 GPS plug into my pwnagotchi via the micro usb port, my problem and that despite my good settings I do not receive any GPS data.

tests performed grep “GPGSA” --line-buffered </ dev / ttyACM0
Despite the captures of my unit whether inside or outside I have no results for the GPS data.
Do you have an idea of the problem ?

Configuration: Raspberrypi Zero WH
U-blox 7 GPS
GPS setting: / dev / ttyACM0 baudrate 9600


1 Like


can I safely asume, that when I get the line:

$ grep "GPGSA" --line-buffered < /dev/ttyACM0

that my GPS Module is not broke, but just did not fix yet?

Somehow the LEDs of my Neo 6m gps do not blink(not even turn on).

Thanks in advance!

1 Like

I’ve got the same setup as described by @Qsolo and i’m also seeing the same issue. Has anyone made any progress on debugging this?
Ive seen advice in other raspberry pi forums saying just leave it running for an hour+ so it can get its initial lock but no luck there. I’ve also tried installing additional packages like gpsd, ntp, some configurations of those, etc with no change.

make sure that you are near a window with a solid view of the sky. just because your phone can get a gps signal does not mean these usb dongles can get a good signal. in many case the usb dongles have chipsets a few generations behind your phone and need a much bigger view of the sky to acquire a signal