Strange HW issue

Hey gang.

So I have built numerous pwnagotchi at this point. All the same H/W.

  • RPi0w
  • 16 gig SD card
  • Waveshare 2.13 v2 rev 2.1
  • Pisugar 1200mah battery pack

This issue is strange.

If I have the whole system together WITHOUT the PiSugar battery pack and just power the unit via the microUSB on the pi…everything is fine. As soon as I attach the PiSugar pack the waveshare goes black on boot and never works.

This is not a pwnagotchi software issue. Its not a RPi issue. It does not appear to be a waveshare issue…

I have charged the PiSugar pack fully. I have layed down Kapton tape in case something was shorting something out… no joy. I can’t seem to deduce why this system will not run off the PiSugar pack when so many others have had no issue.

I have another PiSugar pack coming in a day or so so I can see if there is something wrong with the battery…but im looking for any other clues yall might have to solve this.

Stuck a bit.

TIA

I have NO IDEA WHY…but in a desperate attempt I solder all 40 pins instead of just the 8 needed for the waveshare…and BAM the PiSugar now works perfectly.

This makes literally no sense to me.

Anyone have any insight as to why this would be the case?

If the PiSugar plugin need to communicate with the hardware and don’t get data back (because of the pins wasn’t soldered) probably the software stuck waiting response, stuck before the waveshare initialization or first update with the result of clear screen.
It’s only an idea, I’ve not checked the code to verify this behavior

There is no Pisugar plugin. Pisugar only connects to power - taps into the two power pads on the back on the Rpi.

That is why this is so confusing. Unless I am missing something…

Typing PiSugar, thinking UPS-Lite… my bad! :grin:
Maybe PiSugar make some ground loop that make the pi instable, tomorrow I want to try to investigate about with oscilloscope and data logger because I’m in a similar situation with UPS-Lite: pi work, but sometimes crash, or reboot or freeze

1 Like

All good - I thought I knew what you meant, but I was also afraid I was missing something. I have more hardware coming next week and will continue to test.

Im not sure if it is the Pi crashing or just the Waveshare not displaying…you raise a good point and I will find out the answer to that.

I have made a bunch of units using this hardware layout and only using the 8 pins that the waveshare needs and have never run into this issue until the WS 2,13 V2 went to rev 2.1

Coincidence? Im not sure yet…

I’ve both of version, tomorrow I want to check the board 'cause I think the “rev” stand only for “hardware revision”, only a route optimization on PCB. That make a “more than you think” difference when regards signal and power

1 Like

Thanks for jumping in on this with me

The left one is a waveshare 2.13 BW v2 (shipped with red sticker), the right one is a waveshare 2.13 BW v2_rev2.1 (red sticker still on) and I confirm that both work perfectly powering by usb power port with the same config.yml with
type: 'waveshare_2'
color: 'black'

The differencies I’ve noticed has in the voltage translator component, the v2 mount a Texas Instrument YF08E instead the v2_rev2.1 mount a Texas Instrument YE08.
Tomorrow I wanna try to power them with the UPS_Lite 1.0 to see if they’re ok and to dig into datasheet components if I can find something that can explain the issues

1 Like

So im not sure how the UPS_Lite works at all. The Pisguar has two springy pins on it that touched the back power pads on the RPi0w. Nothing else makes contact with the pi.

I have never had any issues powering my unit via Micro USB cables…they work fine. In the case of this last unit…as soon as I would screw down the Pisugar and use IT as the power source they screen would not work.

Now again - you had a point - I am NOT sure if the whole pi was froze or if just the screen was not displaying properly. That unit is out the door now so I can not test it. As soon as a went and soldered all 40 pins instead of just the 8 waveshare pins…the PiSugar powered the unit and screen properly. At first I thought I had missed one of the 8 for the waveshare,but that was not the case.

I have more hardware coming this week and will continue to do some more testing, but I am glad to heard that there really isnt much difference (as far as this issue goes anyway) between the V2 and the V2 rev2.1

Everything I have ever learned in this world is still currently out the window.

Last night I was setting up a NEW unit. same hardware - different parts. Same problem.

Solder the 8 pin for the waveshare…power via RPi USB…everything is fine. The new unit generates its keys and starts pwning.

I attached the Pisugar to the back of the unit and during boot the waveshare goes black and…nothing.

I solder the other 32 pins…attach the PiSugar …and all is good.

This still makes no sense to me…

Ok, the only thing remained to think is that the Waveshare+PiSugar need the all 3v3 power and ground pins from the RPi instead of the only pins write in official documentation


Maybe, for some reason that actually we can’t figured out, the PiSugar power the pin 1 but not the pin 17, so the possible test is:

  • solder only the usual pin for Waveshare + power pin 17
  • if screen doesn’t work, try solder one another ground pin until it work
1 Like

This is smart. I will try this in the next 24/48 hrs and report.

Well the saga continues. I had built 2 new set ups last night…and the Waveshare(s) worked fine with just the standard 8 pins. Going to continue to call this strange…but also resolved. Until the nest batch.

Mo’ Waveshares. Mo’ problems.

Pin 17 did not do the trick.

I gotta walk away from it at the moment, but will start work and tracking round pins. Gonna be a bit of a slow process…hopefully I figure it out quickly.

Alright.

So tonight was the night I finally tried to tackle this again. It was a huge pain because I would solder one pin, clean it up, reattach the PiSugar, boot it up and wait, decide that is not the pin, dismantle the whole thing and start over with a different pin.

I have now one by one added both 3.3v pins and ALL the GND pins (6,9,14,25,30 and 34)

Whenever I would add a pin and boot the unit somtimes the screen would go all black and stay that way and sometimes it would refresh all white and stay that way.

All those pins and it still doent not work.

Meanwhile less we forget I remove the PiSugar and boot just the pi/waveshare off of USB and it is fine. heh.

I need another break now, but next step is just to solder the remaining of the 40 pins and just call it a day. Its so strange that it is some waveshares and not others… or is it some Pisugars and not others… I can’t even keep track anymore.

Thanks for humoring me yall.