STRONG WIFI DEVICE FOR EVERYONE - I just need help now - driver with monitor mode and frame injection - cannot compile

Image:
image
NETIS WF2190

Chipset: RTL8812AU

I have usb wifi adapter with two high gain antenas. I can even change antenas for different one.
This USB adapter has chipset that kali linux users love because it provides monitoring and promiscous mode.
But currently it cannot be compiled to our pwnagotchi OS image likely because of kernel headers.

https://github.com/aircrack-ng/rtl8812au - link to driver
I can’t compile this on my raspberry pi 4B 4GB RAM

make ARCH=arm CROSS_COMPILE= -C /lib/modules/4.19.81-Re4son-v7l+/build M=/home/pi/rtl8812au modules
make[1]: *** /lib/modules/4.19.81-Re4son-v7l+/build: No such file or directory. Stop.
make: *** [Makefile:2236: modules] Error 2

It is likely related to kernel headers in this image

Try adjusting the platform related building instructions (https://github.com/aircrack-ng/rtl8812au/blob/v5.6.4.2/Makefile):

###################### Platform Related #######################
CONFIG_PLATFORM_I386_PC = y
CONFIG_PLATFORM_ARM_RPI = n
CONFIG_PLATFORM_ARM64_RPI = n

[email protected]:/lib/modules/4.19.81-Re4son-v7l+# uname -a
Linux zerogravity 4.19.81-Re4son-v7+ #1 SMP Wed Nov 6 10:16:47 AEDT 2019 armv7l GNU/Linux

PWNa is using the re4son kernel: https://re4son-kernel.com/re4son-pi-kernel/

Thanks for your links. this device should work without any effort according to your link.
But that is not my own experience.

why should I choose i386 when I have armv7l?

…i386 is the default make option. You should change it in the Makefile before comiling the driver on the pi. Did you do that?

OF course. my rpi4 is armv8 but usualy system image is 32bit armv7 that works on that. I did that and then I had error that I showed.