Temporary failure in name resolution but pwnagotchi can get to numeric ip

I can successfully connect to pwnagotchi from a win 10 machine with ssh.
I shared internet connection as per instructions here.

Also did this:

From a shell in pwnagotchi, I can ping my router as well as all machines on my lan.
I can also ping any ip address on the internet-google for example
ping 64.233.160.3
PING 64.233.160.3 (64.233.160.3) 56(84) bytes of data.
64 bytes from 64.233.160.3: icmp_seq=1 ttl=89 time=55.8 ms
64 bytes from 64.233.160.3: icmp_seq=2 ttl=89 time=55.6 ms
64 bytes from 64.233.160.3: icmp_seq=3 ttl=89 time=56.3 ms

or even a DNS

 ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=114 time=18.5 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=114 time=18.8 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=114 time=24.5 ms

so this is a dns issue.
I tried setting the dns in the properties of the RNDIS adapter to 8.8.8.8 or my router-same problem

Good day mate looks like your DNS is not set up

:),

just add 8.8.8.8 to your /etc/hosts file and you should be adding google to your DNS list, but keep in mind this may reset if your reboot your pi, I think it’s controlled by the network manager so it may auto reconfigure unless you change the default files

just try ping google.com as a test once updated

Check it out: My custom script for connection sharing

Designed for pwnagotchi, works on any raspberry.
It’s just the original connection sharing script with some extra lines to set automatically a DNS in /etc/resolv.conf :wink: