Trouble ssh-ing into RPi3B+

Hi guys, kind of a noob here - I’m having trouble SSH-ing into my pwnagotchi running on a pi3b+ (ver. 1.3.0 of the firmware)

The regular UI works on my inkypi screen, but I’m trying to access the handshake files and access manual mode so I can get into the web UI.

Here’s what I tried:

  • connecting via Ethernet to my windows & mac computers
  • assigned ip to 10.0.0.1 and 255.255.255.0 subnet
  • ssh [email protected] or 10.0.0.1 resulted in: ‘connection refused’ (although the device was detected when I pinged it)
  • tried changing the connection via one of my pi3’s USB ports (USB-A to USB-C) but it didn’t detect it as a network device

I’ve been scouring the subreddit and this forum and heard it has something to do with usb0 and eth0? I have no idea what that means.

This project really has me pumped and I’d like to explore it much further. I’d appreciate it if someone can provide a solution or explanation for my troubles. Thanks in advance!

For raspbian, the default interface for the NIC on the pi3b+ is eth0, whereas the USB data port on the 0W is usb0. I plugged my pi3b+ into my network and grabbed the IP it was assigned and used that to connect. Oddly I had to use my Mac mini to SSH into the pi to disable the usb0 interface before it would let me connect from any other source (windows/Android).

I have access to my router so I can try that. I got an old macbook I can work with. Did you use any specific app/program to ssh into it? Or did u just use terminal?

As I use the mini for a headless server, I ended up just using putty or juicessh (depending on windows/Android) into it and then from there the CLI SSH already on the mini. In case you aren’t familiar with it, the syntax is ssh [email protected]{IP}.

I just setup one on a Pi3 b+. when you plug in the network cable you get an IP on your home network. so your ref: to 10.0.0.2 doesn’t apply. (this is for the USB interface). the USB interface doesn’t show up in networks. ( I assume this is because the Pi has a network port?? not sure) I recall seeing a setting to force USB, but of course can’t find it now

either way check you router for the IP of the pwngotchi and you should be able to ssh (download putty in windows or terminal as you said in mac)