Waveshare 2.7 inch HAT freezed by pwnagotchi

I found the separated header cable that arrived with the display, with that it works fine, so the problem seems the gpio connector on the screen… I’ll try to desolder it (maybe I’ll explore also way to add an rtc board between screen and pi)
So, I finally gave pwnagotchi a try, i used a rpi zero w I had laying aroung (with a nice usb gadget port connector) and a 2.7 inch waveshare eink hat that I bought for a different project.
I have been able to start it by configuring the waveshare27inch config entry in config.toml and it at first blinked a lot like here (Waveshare27inch screen)
Then I got it working, but messed up networking badly and had to reflash, from that point on the screen is dead, stuck on hack the planet screen, and it doesn’t respond to anything
Tried on a fresh pwnagotchi
Installed waveshare examples
tried another example (https://www.instructables.com/id/Waveshare-EPaper-and-a-RaspberryPi/)
but it just doesn’t do anything in pwnagotchi the debug says only
[2019-07-10 03:49:33,035] [DEBUG] Horizontal
[2019-07-10 03:49:49,106] [DEBUG] e-Paper busy
[2019-07-10 03:49:49,148] [DEBUG] e-Paper busy release
and the examples are the same
DEBUG:root:e-Paper busy
DEBUG:root:e-Paper busy release
DEBUG:root:e-Paper busy
DEBUG:root:e-Paper busy release
tried both on the zero w and on another PI3b+
they apparently run but nothing is drawn on screen, any idea? is the screen fried?