Waveshare V.2 Rev2.1 Display Not Working

12672 = BW screen
12915 = BW screen + hat

1 Like

Yes, I have let it sit powered while watching the green activity light. Does not matter how long I wait, there is no output on panel. Again, config.yml is set to ‘waveshare_2’.

I still have never seen this board design, i asked the waveshare section on slack for help figuring this out

That should work, unless there is another issue with the pwnagotchi itself. Have you checked the output of the log? You can find that by connecting to the usb ethernet output and see what it does?

I will try access log tomorrow.

I have the same board and it’s a B/W screen. Mine is working with the default config.

@8bitmega Did you solder the Pi’s GPIO pins yourself? If so, that’s where I’d start checking, giving it a look over to make sure everything is making contact and taking an iron to anything that looks suspect.

You made my day when you said you have same revision of Waveshare panel with no issues. I thought to flash fresh image to different SD card and the panel lit up right away. SD card or image was corrupt. I appreciate all the help.

1 Like

i always test new cards, for example with https://fight-flash-fraud.readthedocs.io/en/latest/usage.html

some has bad speed or are corrupt on read/are fakes.

I have the exact same board like the TO, bought it from “Eckstein” in Germany. I have the same problem, that the display stays blank no matter which config I use. No matter whether v1, v2, black/white/red.

BUT: If you use the supplied cable which goes into the socket on the hat and manually connect the pins on the 40 pin header it works! I verified various things using this approach: Config v1 AND config v2 work both. The example programs from the Waveshare site work as well (C and Python). In all cases it only worked when the display was connected with the cable. It NEVER worked when the board was seated directly on the header.

Tested with Pi Zero WH (with presoldered headers).

My only guess is that the pins are routed wrong from the headers but correctly when using the cable. Any more ideas?

Do not try to edit the config.yml before initial boot. Use default image and then worry about the config.yml later. If any syntax is incorrect in config.yml, the screen does not work. After you have booted with default image, copy default.yml to config.yml and then edit that file.


Hm… this is exactly what I did on my first attempt and I was wondering why I didn’t see anything on the screen… strange… I wonder whether it could be a fault SD if it works by manually connecting the wires instead of placing the hat on the headers. This is not really explainable if you ask me… I’ll give it a try with reinstalling though…

Also, you bought it from another vendor? Might it be that you got a clone? If you connect it manually and it works, might mean you either connected it wrong or the hat is not correct. Note, it stacks like lego.

Dear All,
Sorry to disturb you but i really need your help as i’m encountering hard time trying to running my pwnagotchi.
I have flash the sd card and connected the epaper (please see enclosed photos) but it does not work. Green led blinks for approx a minute and then stop and epaper display nothing … I g=have tried a different sd card but it does not change anything… I have tried to put the config.yml file before and after the first boot but it also give no particular result…
May I ask you help please ?
Thank you very much,
Have a great day,

That display is a waveshare v1
Change your display settings in the config.yml to waveshare_1 instead of waveshare_2
You can notice its a v1 from the blue tab on the screen protector

Dear Arttumiro,
First of all, thank you for your help !
I have flash the sd card once again and modify the config.yml with the proper value but magic does not happen ;-(
Is there somehing else i could try please ?
Thank you very much,

Just jumping in here gents…

I want to echo daubsi problem here. I have soldered up a bunch of these screens now and with the v2.1 running on a battery pack(pi sugar giving power from the pads on the back) the screen just goes full black (or sometimes white) plugging the pwnagotchi via usb and the screen works.

im not sure WHAT the problem could be…maybe just solder the whole header and see if that “fixes” it

I got myself a zero wh with presoldered connectors…
plus I got the waveshare v2rev2.1 and I got no picture too … is there any possible solution to this?
I use the usual config.yml file…
btw … what does the green tab mean on the displayfoil?

Copy image to SD Card, place card into Pi Zero and boot. Do not try to edit config file or change Pwnagotchi image in any way until after Pi is booting and display is working.

1 Like

got a solution!
the waveshare v2 rev2.1 needs to be waveshare_1 and color red in the config file!
all good now…

1 Like

Ive got the exact same issue as you, works with cables but not directly on the gpio. Did you manage to fix it?